使用composer 安装或者更新扩展报错

使用composer 安装或者更新扩展报错

使用composer 安装或者更新扩展的时候可能会报错:
Your configuration does not allow connection to http://ooxx/xxoo.git. See https://getcomposer.org/doc/06-config.md#secure-http for details.

解决方法是设置一个本地或全局的composer配置:

composer config secure-http false

全局设置:

composer config -g secure-http false

Copyright: 采用 知识共享署名4.0 国际许可协议进行许可

Links: https://qingjiaqi.com/2020/09/27/使用composer安装或者更新扩展报错

Buy me a cup of coffee ☕.