PHP

PHP

PHP 删除或者访问宝凑: .user.ini’: Operation not permitted

使用宝塔面板创建网站目录后,在删除/覆盖目录时,出现xxxx.user.ini’:Operationnotpermitted找到报错的.user.ini文件目录输入:chattr-i.user.ini继续操作即可

2020-11-07
61 2

Centos8(Liunx) 中安装PHP7.4 的三种方法和删除它的三种方法

其实这两种方法各有千秋:yum安装:从yum安装来说吧,yum相当于是自动化帮你安装,你不用管软件的依赖关系,在yum安装过程是帮你把软件的全部依赖关系帮你傻瓜式的解决了。而且现在Centos7的服务启动已经换成systemctl命令来控制了。通过yum安装会帮你自动注册服务,你可以通过system

2020-10-26
33 0

使用composer 安装或者更新扩展报错

使用composer 安装或者更新扩展的时候可能会报错:Your configuration does not allow connection to http://ooxx/xxoo.git. See https://getcomposer.org/doc/06-config.md#secure-

2020-09-27
85 0

Linux下面安装php-swoole

需要安装php7新建一个文件夹,作为存储swoole的文件夹然后执行下面相对应的命令,这里是我执行的命令新建文件夹mkdirswoole切入到文件夹中,进行下载安装包wgethttp://pecl.php.net/get/swoole-4.3.1.tgz然后进行解压操作tar-zxvfswoole-

2020-09-05
94 0

Linux下部署PHP项目

1.在服务器上创建指定文件夹2.通过xftp把php项目复制到指定目录下3.通过nginx代理转发访问php项目(类似于前后端分离的vue项目,使用nginx作为web容器)注意:使用了easyswoole的php项目,需要到指定目录下phpeasyswoolestartdevddev:选择的配置文

2020-09-05
116 0

PHP数组转JSON

php数组转json$array = Array('a'=>'one01', 'b'=>'two01', 'c'=>'three01');echo json_encode( $array );结果输出{"a":"one01","b":"two01","c":"three01"}phpjson转数组$

2020-09-05
80 1

Linux 安装PHP 7

请先安装依赖包$yuminstall-ygccgcc-c++makezlibzlib-develpcrepcre-devellibjpeglibjpeg-devellibpnglibpng-develfreetypefreetype-devellibxml2libxml2-develglibcgli

2020-09-05
86 0